invalid prtg web server configuration

Votes:

0

Your Vote:

Up

Down

I just did an upgrade from Ver 9 to Ver 12 and now when I start PRTG Network Monitor I get theis error in prtg gui starter : invalid prtg web server configuration. If I start the browser manually and enter the IP, everything works. It seems the prtg gui starter cannot start the browser anymore for some reason. Thank you!

invalid-prtg prtg-gui-starter web-server

Created on Jan 31, 2013 5:14:15 PM by  mavemania (0) 1



3 Replies

Votes:

0

Your Vote:

Up

Down

Hello,

can you please check if the PRTG Webserver Settings in the PRTG Server Admin Tool are still correct? If they are not, please correct them, if they are correct please save them with "Ok" anyway.

Does it then still throw this error?

best regards.

Created on Jan 31, 2013 5:59:12 PM by  Torsten Lindner [Paessler Support] (19,480) 3 1



Votes:

0

Your Vote:

Up

Down

It seems the web server config it is corrupted. The settings are good: localhost with 8082 port, and it is working on the browser. Here is the kicker: when I hit ok, it tells me the PRTG webserver needs to restart. I click ok and the server restarts. After that the server admin window is still on the screen. I hit ok the second time and a window pops up saying: Not all of the specified IP/port combinations were available for the web server. Port changed from :8082 to :80. I agree and the server admin window disappears. When I go back to server admin tool it shows port 8082, and the browser works on port 8082. I have tried to use the defaukt ports but the same thing happens. Is it any way to delete a file or a registry key and start with a fresh configuration, without uninstalling the whole thing?

Created on Jan 31, 2013 8:29:39 PM by  mavemania (0) 1



Votes:

0

Your Vote:

Up

Down

The "problem" is could also be caused by another application using/blocking the ports I would suggest:

  • Set the PRTG Core Service to be of "Manual"-Start type
  • Reboot the entire system
  • Check with netstat if the ports you want PRTG to bind are all available
  • Open the "PRTG Server Admin", set the IP & Port and start the Core Service

Does this work? If so, afterwards. please set the Core Service to be of automatic start type again.

Created on Feb 1, 2013 1:13:21 PM by  Torsten Lindner [Paessler Support] (19,480) 3 1



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.

PRTG
Network Monitor
Intuitive to Use.
Easy to manage.

150.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Visit
www.paessler.com

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

Top Tags


View all Tags