Can GMail / Google Apps be used for SMTP relay?

Votes:

0

Your Vote:

Up

Down

SMTP Delivery in PRTG works in Automatic SMTP Delivery Mechanism, but I wanted to know why it doesn't work if I enter the SMTP server relay info myself (same account info).

If I select via SMTP Relay Server option, the logs show: Error sending "Email": Connection failed ("smtp.gmail.com")

Settings Used:

Sender E-Mail: <User@GoogleAppsDomain.com>
Sender Name: <User Name>
HELO Ident: <ServerHostName>
SMTP Relay Server: smtp.gmail.com
SMTP Relay SMTP Port: 587
SMTP Relay Authentication: SASL authentication is required (also tried std smtp)
SMTP Relay Username:  <User@GoogleAppsDomain.com>
SMTP Relay Password: <User Password>
Use TLS: <yes>

Same SMTP / account information also works in the sendemail.exe utility you can find online. Is there something I'm missing as to why it won't work on PRTG?

gmail google-apps prtg smtp smtp-gmail-com

Created on Mar 21, 2010 9:08:09 AM by  candlebox1369 (0) 1

Last change on Mar 23, 2010 11:52:56 AM by  Daniel Zobel [Paessler Support] (24,941) 3 3



Best Answer

Accepted Answer

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 8 or later

Use a Gmail Address for PRTG SMTP Delivery

We successfully tested a Gmail address / Gmail SMTP server for sending out email notifications with PRTG. In PRTG's web interface, select Setup | System Administration | Notification Delivery from the main menu.

Settings for Gmail in PRTG 13.3 or later

Please use the settings as indicated in the screenshot below.

Note: Make sure you replace the user part of the email address by your own gmail username (twice). When using a Gmail hosted address, use username@hostname.tld.

SMTP Delivery Settings

Note: One of our customers used the SMTP port 587 in order to get SMTP relay working.

Settings for Gmail in PRTG 9 and 12

Settings in these PRTG versions are very similar to PRTG 13.3 and later. Please see a sample screen shot below.

Note: Make sure you replace the user part of the email address by your own gmail username (twice). When using a Gmail hosted address, use username@hostname.tld.

Settings for Gmail in PRTG 8 (deprecated)

PRTG OptionValue when Using Gmail
SMTP Delivery Mechanism• Use SMTP relay server
Sender E-Mailusername@gmail.com ( * )
Sender Name[any]
HELO Ident[any]
SMTP Relay Serversmtp.gmail.com
SMTP Relay SMTP Port465
SMTP Relay Authentication• Use standard SMTP authentication
SSL MethodTLS V1
SMTP Relay Usernameusername@gmail.com ( * )
SMTP Relay Password[Your Gmail password]
Security• Encrypt data using Transport-Level Security (TLS)

( * ) username@hostname.tld when using a Gmail hosted address.

Note: Even for German Google Mail addresses ending in @googlemail.com, please use the settings as stated above.

Trouble Shooting

In order to test the new settings, go to Setup | Account Settings | Notifications and next to the Mail to admin notification, click on the Test link. An email should be sent out immediately.

If you have any problems sending mails, please check PRTG's Logs for respective entries. Please make sure your firewall settings allow a connection on port 465!

Created on Jun 14, 2011 9:25:04 AM by  Daniel Zobel [Paessler Support] (24,941) 3 3

Last change on Jul 15, 2013 11:39:53 AM by  Gerald Schoch [Paessler Support] (6,173) 2 1



6 Replies

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 7

We actually managed to get a GMail / Googlemail account to relay notification mails using the following settings:

OptionSetting
SMTP relay serversmtp.gmail.com
SMTP relay port465
SMTP Relay AuthenticationUse standard SMTP authentication
Use TLSon

Please also see Configuring other mail clients from GMail help.

Created on Mar 22, 2010 10:56:44 AM by  Patrick Hutter [Paessler Support] (6,894) 3 3

Last change on Jun 14, 2011 9:07:26 AM by  Daniel Zobel [Paessler Support] (24,941) 3 3



Votes:

0

Your Vote:

Up

Down

Tried it and worked. Thanks.

Created on Mar 24, 2010 1:54:11 AM by  candlebox1369 (0) 1



Votes:

0

Your Vote:

Up

Down

Hi, We have just recently installed prtg and we still can't send out notifications. Even after changing to the above settings we still get the 'Error sending "Email": Connection failed ("smtp.gmail.com")" message. I have left the HELO Ident with the default settings -WIN-JN6NM66AF2G. Not sure if this is the reason for this. Hope you can shed some light.

Created on Jun 9, 2011 3:47:42 AM by  amirhussin (0)



Accepted Answer

Votes:

0

Your Vote:

Up

Down

This article applies to PRTG Network Monitor 8 or later

Use a Gmail Address for PRTG SMTP Delivery

We successfully tested a Gmail address / Gmail SMTP server for sending out email notifications with PRTG. In PRTG's web interface, select Setup | System Administration | Notification Delivery from the main menu.

Settings for Gmail in PRTG 13.3 or later

Please use the settings as indicated in the screenshot below.

Note: Make sure you replace the user part of the email address by your own gmail username (twice). When using a Gmail hosted address, use username@hostname.tld.

SMTP Delivery Settings

Note: One of our customers used the SMTP port 587 in order to get SMTP relay working.

Settings for Gmail in PRTG 9 and 12

Settings in these PRTG versions are very similar to PRTG 13.3 and later. Please see a sample screen shot below.

Note: Make sure you replace the user part of the email address by your own gmail username (twice). When using a Gmail hosted address, use username@hostname.tld.

Settings for Gmail in PRTG 8 (deprecated)

PRTG OptionValue when Using Gmail
SMTP Delivery Mechanism• Use SMTP relay server
Sender E-Mailusername@gmail.com ( * )
Sender Name[any]
HELO Ident[any]
SMTP Relay Serversmtp.gmail.com
SMTP Relay SMTP Port465
SMTP Relay Authentication• Use standard SMTP authentication
SSL MethodTLS V1
SMTP Relay Usernameusername@gmail.com ( * )
SMTP Relay Password[Your Gmail password]
Security• Encrypt data using Transport-Level Security (TLS)

( * ) username@hostname.tld when using a Gmail hosted address.

Note: Even for German Google Mail addresses ending in @googlemail.com, please use the settings as stated above.

Trouble Shooting

In order to test the new settings, go to Setup | Account Settings | Notifications and next to the Mail to admin notification, click on the Test link. An email should be sent out immediately.

If you have any problems sending mails, please check PRTG's Logs for respective entries. Please make sure your firewall settings allow a connection on port 465!

Created on Jun 14, 2011 9:25:04 AM by  Daniel Zobel [Paessler Support] (24,941) 3 3

Last change on Jul 15, 2013 11:39:53 AM by  Gerald Schoch [Paessler Support] (6,173) 2 1



Votes:

0

Your Vote:

Up

Down

Currently running PRTG Network Monitor 13. Tried to use my Gmail account based on the information supplied above for "Setting for PRTG 9" but it continued to fail.

After researching it a bit further, found that there is another port "587" that can be used for the SMTP Relay SMTP port. Updated new port, saved changes, tested and received the notification as desired.

Created on Mar 20, 2013 12:51:22 PM by  ppatullo (0)



Votes:

0

Your Vote:

Up

Down

@ppatullo: Thank you for the information!

Created on Mar 20, 2013 12:53:09 PM by  Konstantin Wolff [Paessler Support] (3,860) 3 2



Please log in or register to enter your reply.


Disclaimer: The information in the Paessler Knowledge Base comes without warranty of any kind. Use at your own risk. Before applying any instructions please exercise proper system administrator housekeeping. You must make sure that a proper backup of all your data is available.

PRTG
Network Monitor
Intuitive to Use.
Easy to manage.

150.000 administrators have chosen PRTG to monitor their network. Find out how you can reduce cost, increase QoS and ease planning, as well.

Visit
www.paessler.com

What is this?

This knowledgebase contains questions and answers about PRTG Network Monitor and network monitoring in general. You are invited to get involved by asking and answering questions!

Learn more

Top Tags


View all Tags